Results 1 to 2 of 2

Thread: Upgrade vShare 2.8.1 to vShare 2.9

  1. #1
    Join Date
    Apr 2007

    Default Upgrade vShare 2.8.1 to vShare 2.9

    Upgrade vShare 2.8.1 to vShare 2.9

    You will need MySQLi to run vShare 2.9 as PHP MySQL extension is deprecated on PHP 5.5.x.


    Before you start upgrading, take backup of your site including database and files.

    If you are using version older than 2.5, you need to upgrade to vShare 2.5 or higher before upgrading

    You can see upgrade instructions for older versions of vshare at

    If you are not familiar with installing scripts, don't do it yourself. Paid vShare upgrade service available from [email protected] for $5. If you are using too old version, its better get paid upgrade service, so you don't have to do multiple upgrades yourself.

    Template Changes

    We tried not to change web site template files. So most of the front end templates will work with out any change.

    templates/admin folder need to reupload as all admin area templates are changed in vShare 2.9.

    If you have custom modifications, do not delete or rewrite existing templates folder.


    I suggest you to move the files and folders to a temporary folder, so you can refer them if needed. File Manager in Cpanel Control panel will allow you to move files and folders. If you move large files, wait some time until it finished.

    Uploading vShare 2.9

    Download vShare 2.9 from Members Area or from

    Use email used to purchase to get download link.

    Extract the zip file. Delete following files and folders (these folders and files already present in your server.)


    Upload rest of the file to server. Make sure you don't overwrite file include/config.php in server.

    Run upgrade script

    After you uploaded new files, you need to run upgrade.php to upgrade database.

    After upgrade finished, delete the install folder.

    Common Errors

    1. Fatal error: Uncaught --> Smarty: property 'rendered_template' does not exist. This is because you have old compiled smarty templates exists in templates_c folder. Delete all smarty template cache files (*.tpl.php) from templates_c folder.

  2. #2
    Join Date
    Sep 2008


    Default (non-upgrade) installation... Does not appear to actually upload any files (regardless of uploader chosen). No errors are given. However, the uploaded file is definitely not being added to the server. Am looking through the code to see what it could potentially be.


    So, I have discovered the issue. Not an issue with the script per say. Rather, it's an issue when use with Plesk and nginx. Found the solution and fixed it.
    Last edited by bplex; 05-22-2014 at 03:37 PM.
    vShare Solutions
    Custom vShare Modules and Services

    Now, your visitors can watch videos on your site using their mobile or tablet device with the Mobility Mod for vShare 2.8!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts